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Preface
Welcome to BrioQuery. This chapter provides an overview of the 
BrioQuery Handbook, including:

• an overview of the Handbook sections

• references to other BrioQuery documentation

• a discussion of the conventions used in the BrioQuery Handbook

• instructions for contacting Brio
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About BrioQuery Editions
BrioQuery is available in three different editions: Navigator, Explorer, and 
Designer. 

The multi-edition structure takes into account the differences in the ways 
users work with databases, their information needs, their technical 
experience with client/server database technology, and the way 
BrioQuery is deployed in their computing environment.

Each edition incorporates core query, analysis and reporting features, and 
adds increasing levels of Data Modeling functionality:

BrioQuery™ Navigator 

Navigators are information consumers. They generally need access to the 
same types of information on a daily basis, do not have a strong technical 
understanding of databases, and are focused on retrieving data for use in 
their work.

The feature set available to Navigator users is weighted towards 
information processing. Navigators access information through BrioQuery 
Data Models created by an administrator. The Data Models shield 
Navigators from complicated database schema. Navigators can use Data 
Models to create their own queries and use all of BrioQuery’s reporting 
and analysis features to work with information. 

Parts I, II and III of this Handbook are written with Navigators in mind. 
Navigators might also find relevant information in Part IV.

BrioQuery™ Explorer 

Explorers are information seekers. They are power users who often 
combine information from different tables or different databases to 
complete their work. They understand the database table and join 
structure and are comfortable finding the information they need in 
the database.

The Explorer edition adds Data Modeling to the Navigator feature set. 
Explorers can use distributed Data Models, or create new Data Models 
from database tables for their own or distributed use. 

Explorers will be interested in Parts I, II, III and IV with some interest 
in Part V.
xii



BrioQuery™ Designer

Designers are information facilitators. They are often database 
administrators deeply experienced with client/server connectivity and 
database schema. In addition to their own query needs, they manage the 
BrioQuery environment by providing pre-built Data Models which they 
distribute to Navigator and Explorer users.

The Designer edition of BrioQuery adds Repository creation, 
management, and auditing to the Explorer feature set. The BrioQuery 
Repository is a version-controlled database storehouse of Data Models 
that can be implemented across an enterprise. Navigators and Explorers 
can download pre-built Data Models from the Repository and access 
information quickly and efficiently.

Part V is particularly written with the Designer in mind. This section 
explains how to administer BrioQuery effectively to maximize success in 
the business environment.

Who Should Use this Handbook
The BrioQuery Handbook documents features and concepts for 
BrioQuery Navigator, Explorer, and Designer users. 

This handbook includes information that applies to all supported operating 
systems: Microsoft Windows™, MacOS™, and Motif® (UNIX) 
environments.

What this Handbook Contains
This Handbook is organized in order of complexity, beginning with 
features that are common to all BrioQuery users (Navigator, Explorer, and 
Designer) and progressively introducing more advanced features. 
Database Administrators should turn to Part V: “BrioQuery 
Administration”for guidance on setting up the database connection and 
other setup procedures.

This guide contains five parts:

• Part I: “Getting Started” provides an overview of the many powerful 
features in BrioQuery. In addition to an Introduction, this section 
includes a Quick Start, a conceptual introduction to data analysis and a 
reference chapter on the BrioQuery workspace. 
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This section can help the new user get up and running quickly. In 
addition, the conceptual background can help Navigators make the 
most of BrioQuery. 

• Part II: “Querying and Results” explains the drag-and-drop technique 
for generating a query and working with the results returned from the 
database. In addition, this section explains how to set limits, sort data 
and perform computations on the data. 

• Part III: “Reports” describes how to use the sophisticated features in 
Pivot and Interactive Charting to analyze your data and create attractive 
Detail reports. It also includes chapters on general report features, EIS 
tabs and Scheduling. 

• Part IV: “Automating BrioQuery” has information for all users about 
how to schedule automatic querying with use of the BrioQuery.Server. 
It also covers the EIS tab a streamlined, push-button approach to 
querying a database. 

• Part V: “BrioQuery Administration” is for BrioQuery Explorer and 
Designer users primarily. It provides information on the fundamental 
structure used to query databases. It describes administrative features, 
such as how to build and customize Data Models and how to manage 
the BrioQuery Repository.

• Part VI: “Appendices” provides a series of tables for reference with 
information about specific Data Functions, scripting commands and 
other useful information. In addition, information about using 
BrioQuery to connect to Essbase databases is provided.
xiv



Related Documentation
The BrioQuery Handbook is one component of the BrioQuery 
documentation suite. The components described below provide 
complementary or additional information about BrioQuery. 

Printed Documentation

Depending on what version of BrioQuery you use, you received one of 
the following installation guides:

• Installing BrioQuery for Windows/Windows ’95 and Macintosh/Power 
Macintosh tells you how to install and use BrioQuery on computers 
running Microsoft Windows/Windows 95 or on your Macintosh or 
Power Macintosh computer

• Installing BrioQuery for Motif tells you how to install and use BrioQuery 
in the Motif (UNIX) environment.

On-line Help

When running BrioQuery for Windows or Macintosh, you have access to 
a comprehensive on-line help system.

• BrioQuery Help complements the printed documentation by providing 
descriptions and step-by-step instructions for all BrioQuery features. 
Some infrequently used features are only discussed in on-line help. 

• The Connections Guide tells Windows and Macintosh users how to 
connect to your database server using BrioQuery. The Windows and 
Macintosh Connections Guide is available only as an on-line help file. 
Connection information for the Motif version of BrioQuery is included 
in Installing BrioQuery for Motif.

To view on-line help using Windows:

Choose BrioQuery Help (or Connections Guide) from the Help menu.

To view on-line help using the Macintosh:

Choose BrioQuery Help (or BrioQuery Connections Guide) from the 
Apple menu.
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Conventions
This Handbook uses the following conventions.

Menu Commands

BrioQuery documentation uses the “>” symbol to simplify the 
explanation of Menu choices. For example, Choose Insert > New Pivot 
indicates that you select New Pivot from under the Insert menu option. 

Dialog Boxes and Windows

BrioQuery is available for Microsoft Windows, Macintosh, and Motif 
(UNIX) environments. BrioQuery documentation describes features that 
are available in all configurations of BrioQuery. Since most dialog boxes 
and windows are similar on all platforms, screen shots may originate from 
the Macintosh, Windows, or Motif environments. Different versions of a 
dialog box or window are displayed only when there is a substantial 
difference between platforms.

Text and Icons

References to BrioQuery documentation is shown in italic font. 
For example: BrioQuery Connections Guide.

Information you enter, for example when you’re writing BrioQuery 
scripts, is in courier  font. 

Important This icon indicates an important or key point. 

Note Notes contain helpful information that is not contained in general 
explanations or procedures.

Technical Note  Provides technical information that may be of interest 
to more specialized readers.

BrioQuery Explorer/Designer Note  Indicates that specific information is 
provided for Explorers or Designers.

>
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Tip  provides information that makes it easier to achieve the results 
you wish.

This icon identifies information that is unique to the version of BrioQuery 
running under Microsoft Windows or Windows ‘95.

This icon identifies information that is unique to the version of BrioQuery 
running under a version of the MacOS.

This icon identifies information that applies only to the Motif version of 
BrioQuery.

Contacting Brio
We like to hear from our customers!

Please contact Brio Technology or visit our web page to receive updates, 
technical bulletins, and other information on Brio products and events. 
For registered owners of BrioQuery, Brio provides a variety of fee-based 
technical support plans. 

Note Have your BrioQuery serial number ready when calling Brio for 
technical assistance. For faxed requests and electronic mail, always 
include your serial number in the message. 

To view your serial number:

Choose Help > About BrioQuery.

Choose About BrioQuery from the Apple menu (Macintosh).

For easy reference, write your serial number, or place the serial number 
sticker from your BrioQuery box here.

Main (415) 856-8000 (415) 856-8020 fax
Technical Support (415) 845-4731 support@brio.com
Sales (800) TRY-BRIO sales@brio.com

World Wide Web http://www.brio.com
FTP ftp.brio.com

UNIX
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This chapter introduces the conceptual background of business 
intelligence software tools, providing an overview of how anyone—both 
technical and non-technical people—can use BrioQuery to access and 
analyze database information. 

The chapter also describes the integrated feature set which makes 
BrioQuery the leading desktop business intelligence tool, and a complete 
listing of what’s new in version 5.0.
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Understanding Business Intelligence Tools

At the core of the modern enterprise is database information. Each day, 
businesses collect and process vast amounts of data—much of which 
remains unused because business people are unable to extract and 
visualize it to make its meanings clear. 

The introduction of data warehouses and data marts have addressed this 
problem, grouping legacy data stores into new database configurations, 
and restructuring data to make it more comprehensible and navigable by 
non-technical users. Yet retrieving information from databases can still be 
a difficult proposition for business users who are not equipped with the 
right tools. 

While they are often familiar with spreadsheets, and may have passing 
experience with reporting and even query tools, the majority of business 
users are still relatively new to business intelligence tools—tools which 
allow them to bridge the gap between a business question and the 
answers held somewhere in a technological storehouse of information: 
the database. 

Business intelligence software should integrate the capabilities of other 
business software products, minimizing the number of applications 
necessary on the desktop. Yet this must be accomplished without 
compromising the strength of analysis and reporting features, and 
without extravagant consumption of network and IT resources. The best 
business intelligence software makes each business user self-sufficient 
to the extent of their needs as librarian, researcher, analyst and reporter 
of corporate data. 

About BrioQuery

BrioQuery is the principal product of the Brio Enterprise, a complete 
enterprise business intelligence solution. Providing ad hoc client/server 
querying, reporting and OLAP, BrioQuery connects business users to 
data and supplies a complete set of tools to support business decisions, 
all in one application.

• BrioQuery insulates users from the complexities of SQL through a 
simple drag and drop query interface. Support for a unified, enterprise-
level metadata source allows non-technical types to browse and select 
1-2 Part I:  Getting Started
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familiar business entities such as “sales” and “annual revenue” rather 
than obscure entity names. 

• BrioQuery provides reporting, charting and analytical processing 
through a unique, intuitive tabbed interface. Drawing from a central 
data set, users can create a portfolio of multiple reports, customizing 
each and drilling anywhere through hierarchical levels and groupings of 
data. 

Figure 1-1 BrioQuery business intelligence.

Step 1: Business Questions
An executive formulates a question 
about business trends. 

Step 2: Creating a Query
BrioQuery translates the question into SQL statements 
and sends them to the database.

Step 3:Processing 
The database processes the 
SQL and returns the desired 
data to BrioQuery.

Step 4: Results
BrioQuery displays the results in 
tabular format 

1

2

3

4

5
Step 5: Visualization
The user is free to use and reuse the results 
data to create multiple BrioQuery reports 
and analyze data.
Chapter 1: Introducing BrioQuery 1-3



• BrioQuery is easy to administer across the enterprise. The absence of 
proprietary metadata makes BrioQuery an out-of-the-box solution. 
Advanced Data Modeling, document control and scripting are included 
in the same application. A centralized repository stores and 
automatically updates Data Models to reflect changes in the database. 

• When extrapolated to the BrioQuery Enterprise product line, BrioQuery 
serves as the source of a complete business intelligence delivery 
system. Working in tandem with BrioQuery.Server, BrioQuery can 
schedule queries, and deliver them to users for viewing across the 
intranet through web browsers. 

About BrioQuery Documents

With BrioQuery, you work in convenient document files that consolidate 
specifications for querying, limiting, sorting, and computing data stored 
on the database server. The document also retains the retrieved data set 
and reports created from the queried data set.

Each BrioQuery document can include:

• a Data Model—a graphical representation of the database

• a query for retrieving a subset of data from the database

• a results set displayed in a spreadsheet-style format

• Detail reports presenting customized, hierarchical views of your data

• multidimensional Pivot reports that permit drill-down analysis of 
data results

• charts that graphically display your query results and allow different 
angles of vision on the data.

Working With Data Models

BrioQuery makes the database accessible by presenting its contents 
through custom views called Data Models. Data Models are focused, 
visual representations of actual database tables. Through the Data Model, 
users interact with the database, browsing and specifying which data is 
to be retrieved for analysis.
1-4 Part I:  Getting Started
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Figure 1-2 A Data Model and associated query on the Request line.

Data Models can make the database more accessible by:

• substituting descriptive names for arcane database table and 
column names

• creating custom views of the data

• adding computed fields for performing calculations on the 
retrieved data

In addition to standard Data Models derived from database tables, 
BrioQuery lets you create meta topics—virtual views independent of the 
actual database. You can use meta topics to standardize complex 
calculations and simplify views of the underlying data with intuitive topics 
customized for business needs.

Depending on the edition of BrioQuery, users can create their own Data 
Models, or they can be provided by other users or through the centralized 
BrioQuery Repository, a catalogued storehouse of database views for 
querying. 

Analysis and Reporting

Once a query is processed and data results are returned to the user 
desktop, BrioQuery’s powerful reporting and analysis tools are available 
for creating custom views, cross-tabs, and drill-downs that let users 
“slice and dice” data to view the multidimensional relationships 
contained within. 

Create as many different views of the collected data as you wish, 
displaying your information in any form and from any angle possible. At 
Chapter 1: Introducing BrioQuery 1-5



any time, you can reconnect to the server and update your reports and 
charts with fresh data from the database.

Figure 1-3 Drilling-down into detail data in a Pivot report.

BrioQuery also provides the unique option of working autonomously with 
data after disconnecting from the server. Even without a database 
connection, users can continue to analyze data and produce reports. 
You can save results in the desired format for additional refinement 
in BrioQuery, or even export the data to other applications for 
further analysis.

BrioQuery Features

BrioQuery provides a range of features unmatched in any other query and 
reporting tool of comparable price, including:

• support for all industry-standard databases, including AS/400, Informix, 
Oracle, Sybase, Microsoft SQL Server, Red Brick Warehouse, 
Broadbase and Essbase.

• a point-and-click interface for intuitive custom query and report building

• support for Microsoft Windows, the MacOS, and Motif (UNIX), with 
complete file compatibility between the platforms

• easy, non-procedural navigation between query and reporting sections 
through use of tabs

• client editions that maintain a consistent interface for the client and 
administrative editions of BrioQuery, but that provide different levels of 
access to BrioQuery features

• an extensive online help system and the on-screen BrioQuery Advisor 
provide user assistance for features and document construction
1-6 Part I:  Getting Started
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• the Outliner, a drag-and-drop tool for developing reports and analyzing 
data

• interactive Pivot reporting that lets you perform unrestricted drill-down 
analysis of different data relationships

• extensive formatting tools for creating compelling data presentations

• an easy-to-use, interactive charting utility for graphically displaying and 
drilling-down into data

Figure 1-4 Interactive charting is an intuitive and rapid way to analyze data 
and build eye-catching presentations.

• the BrioQuery Repository, a library of Data Models, queries, report 
templates, and style sheets that can be shared–and intelligently 
deployed–enterprise-wide

• enterprise-wide auditing of Data Models

• a complete scripting language, and add-ins which allow scripting from 
other applications

Year “2000” Compliance

BrioQuery is fully year “2000” compliant, with internal date handling 
thoroughly tested and proven effective in retrieving dates well past the 
year 3000. BrioQuery’s Results window computations also have tested 
correctly when handling dates past the year 2000. Keep in mind, 
however, that third-party DBMS and API products used in conjunction 
with BrioQuery are not necessarily guaranteed to support dates past the 
year 2000. Check with your DBMS or API vendor for details.
Chapter 1: Introducing BrioQuery 1-7



What’s New in 5.0?

BrioQuery 5.0 has many new features and capabilities that make data 
analysis easier while providing still greater flexibility in how data is 
presented and interpreted.

The following highlights point you to the new features. More detailed 
descriptions are provided throughout the handbook.

General Improvements

• Menu Restructuring to simplify navigation.

• Global font preferences (Edit > Preferences) to define default fonts for 
all BrioQuery sections (see “Default Formats” on page 13-16).

• Ability to hide section tabs and request line items (see“Hiding 
Reports” on page 13-4).

• Tooltips, when you pass over an icon on the toolbar.

Querying

• Multiple Data Sources — (“heterogeneous join”) allows a previously 
built BQY file to be included in second document as if it were a topic. 
Ability to join queries on separate databases (see “Stored Procedures” 
on page 5-19).

• Process to Database Table — returns results of query to a new table in 
the database (see “Processing to a Database Table” on page 5-22).

• Support for Essbase 4.0 (Appendix A: Querying Essbase)

• Weighting Factors — a data function to correct skewed data by 
weighting values relative to others. The weighted column is available 
for use in Pivot reports (“Setting up Weighted Values” on page 10-25).

• Show Values Lookup — a request for data from one column can be 
redirected to show values from another more meaningful column in 
another table (see“The Lookups Tab” on page 18-24).

• Size Query Before Process — determines the number of rows a 
query will retrieve before the actual query (see “Sizing Queries” on 
page 5-17).
1-8 Part I:  Getting Started



D
E

S
IG

N
E

R
  •

  E
X

P
L

O
R

E
R

  •
  N

A
V

IG
A

T
O

R

• Topic Priority — allows topic order to be reordered for the query and 
can optimize querying (see “Topic Priority” on page 17-9).

• Computed Column Results as Meta Topic Item — for Designers 
to design a post-query calculation that appears as a meta topic in 
the Query window (“Creating Computed Meta Topic Items” on 
page 18-5).

• Option to Disable Non-Joined Queries (see “Connection Preferences” 
on page B-2).

Results

• Importing Local Files — directly to result section (see “Importing Data 
Files” on page 5-19).

• Custom Hierarchies — allowing you to group columns in the Results 
section when your database does not contain the precise level of 
summary you need (see “Grouping Columns” on page 6-3).

Pivot

• Computed Facts — computed columns may be added to Pivot fact 
area (“Computed Items in Results and Pivot Sections” on page 8-5).

• Enhanced Total Formulas — special data functions for summarizing 
“surface” values rather than the original underlying values (see “Total 
Functions” on page 10-21). 

• Chart This Pivot — automatic generation of a chart based on current 
Pivot report data (see “Chart This Pivot” on page 10-16).

• Drillup — enables the drilling up out of data that previously was drilled 
into (“To drill-up from the data” on page 10-15).

Chart

• New chart types — Line, Area, Line-Bar combination charts (Chapter 
11: Interactive Charting).

• Second, Independent Y axis — a second y axis for use in comparing 
facts having a widely varying scale (“Using the Second Y axis” on 
page 11-27).
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• Shading Patterns — alternative color patterns for chart objects for 
sending chart to black and white printers (see“To apply styles to 
charts” on page 11-37)

• Rotation Interface — to help in rotating the viewing angle of a chart 
(see “To rotate a chart (except pie charts)” on page 11-38).

• Pivot This Chart — automatic generation of a Pivot report from an 
already designed Chart (“Pivot This Chart” on page 11-45)

Scripting 

EIS

EIS is a new section tab (“Executive Information Systems”) providing a 
streamlined, push-button approach to querying. Designer and Explorer 
users can create a console which retrieves data and runs reports with a 
simple mouse click (Chapter 14: EIS and Automation).

Script Related

• Open and Close Document Events — allow script actions to be invoked 
when a document is opened or closed.

• Launch Other Applications — allows an EIS tab to include a button to 
launch another application, such as Excel.

• Results Limit Command — to manipulate the limits defined in the 
results section.

For these commands, see Appendix B: Reference Tables.

Scheduling 

• BrioQuery can now schedule documents for processing by the 
BrioQuery Server and monitor job repository tables (Chapter 15: 
Scheduling).

Repository

• create tables from BrioQuery

• new 5.0 Hub repository and repository group feature (see Chapter 19: 
Managing the BrioQuery Repository).
1-10 Part I:  Getting Started



D
E

S
IG

N
E

R
  •

  
2

E

A Tour of Brio Query
X
P

L
O

R
E

R
  •

  N
A

V
IG

A
T

O
R

Welcome to BrioQuery! As a new user, you want a quick overview 
of BrioQuery’s powerful capabilities. You want to know, “What can 
BrioQuery do for me?” The answer is, “A great deal,” if you invest a 
little time to take this tour. 

The tour provides a quick introduction to some of the basic features of 
BrioQuery and familiarizes you with the desktop workspace. In addition, 
you learn some of the basic skills for analyzing data. With this foundation 
in hand, you will more rapidly reap the rewards of BrioQuery. 

To take the tour, you need to have BrioQuery installed on your desktop. 
A connection to your company database is not necessary at this point. 
2-1



Step One: Start BrioQuery
To start BrioQuery using Windows

Go to Start/Programs and select BrioQuery or double-click the BrioQuery 
icon in the BrioQuery folder.

Note In a Windows 95 environment, BrioQuery installs in 
C:\Program Files\BrioQry. In Win 3.1, BrioQuery installs in C:\BrioQry. 

To start BrioQuery using the Macintosh

Double-click the BrioQuery icon in the BrioQuery folder.

The BrioQuery Workspace

When you start BrioQuery, the workspace appears, providing a starting 
point for performing database operations.

Figure 2-1 The BrioQuery workspace is the starting point for performing 
database operations.

Tool bars and buttons provide quick access to most BrioQuery functions.

Menu bar
Standard 
toolbar Format 

toolbar

Request 
line

Limit 
line

Document 
workspace

Section tabs
Status bar

Scroll arrows

Sort
line
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Step Two: Opening and Saving a Sample File
To familiarize yourself with BrioQuery’s basic functions, you can work 
with one of the sample files provided when BrioQuery is installed. 

To open a sample file

1 Choose File > Open. 

Note Brio documentation uses the convention “File > Open” 
to indicate that you select Open from the File menu.

2 Locate the Sample folder in the BrioQuery folder.

3 Select the Sample1.bqy file.

4 Click Open.

Figure 2-2 One Section of the Sample File.
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To save a practice copy

To preserve the sample in its original condition, save a copy of the sample 
under a new name. Use this copy for the exercises below.

1 Choose File > Save Results With Data.

Note Make sure there is a check mark by Save Results With Data. 
Otherwise, results will not be saved.

2 Choose File > Save As.

3 Give your file a name (such as practice.bqy) and click Save.

Now you are ready to explore the BrioQuery workspace.

Step Three: Finding Your Way
The BrioQuery window includes five separate sections, accessed by 
clicking on the section tabs at the bottom of the window (Figure 2-3). 

To move to a section

Click a section tab at the bottom of the window

BrioQuery displays the section you selected.

Figure 2-3 Click on a section tab to navigate between the sections of the workspace.

Note If you can’t see all the tabs, use the scroll arrows to scroll 
horizontally to view all the section tabs.

Query 
section 
tab

Results 
section 
tab

Pivot 
section tab

Detail 
section tab

Chart 
section tab

Scroll through sections
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Step Four: Introducing Query
Click the Query section tab 

The Query section is the space in which you build questions for 
the database. For the Quick Start, you won’t actually generate any 
queries. That procedure comes later when you learn about 
establishing database connections (“Step Nine: Returning to Query” 
on page 2-18). For this exercise, you simply learn what a query 
involves.

Figure 2-4 The query section

The sample illustrates a simple query already conducted for a fictitious 
company named Personal Computer Warehouse (PCW). The structure of 
PCW database is discussed in “Introducing Personal Computer 
Warehouse” on page 3-3. During this exercise, you will learn more about 
this company as you develop your own reports from a query. 

PCW distributes desktop computer supplies to a number of computer 
chains located throughout the United States. In order to predict trends 
and locate strengths and weaknesses in its distribution techniques, PCW 
warehouses extensive data.

In the sample file, you find four Topics or logical groupings depicted 
visually in the workspace. These four Topics represent tables in the PCW 
database. Each Topic contains a list of items which represent fields or 

Drag items from 
Topics to the 
Request line
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rows of data in the database. In Sample 1, you see “Customers”, 
“Sales”, “Items” and “Periods”.

Each item in a Topic may be dragged and dropped to the Request line. 
When a query is submitted, BrioQuery returns data on all the items 
present on the Request line. In the sample, several items from each table 
have already been dragged to the Request line (e.g., Sum (Amount), Line 
Name, Quarter, Year...).

Figure 2-5 Tables in the PCW database
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Step Five: Getting Some Results 
Results from a query naturally appear in the Results section. In the 
sample before you, each column of results corresponds to items on the 
Request line in the Query Section.

To go to the Results section

1 Click the Results section tab.

2 Tab back and forth to compare the items in the Query and 
Results sections.

Figure 2-6 The Results section.
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Managing the Results Section

There are various techniques for making your data more manageable right 
away in the Results section.

To reorder and sort columns of data

1 Experiment reordering columns by dragging one column to the left or 
right of another column.

2 Choose View > Sort Line, if the Sort Line is not already available. Drag 
“Item Type” to the Sort Line. 

3 Click Sort Now to group items by type.

To limit data that appears

At times you may have more data in a column than you wish. You can 
limit the data within a column with the Limit line.

1 Choose View > Limit Line, if the Limit Line is not already available. 
Drag “Year Number” to the Limit Line. A Limit window appears. 

2 Click Show Values and then select 1994. 

3 Click OK. All data from 1995 is dropped from the Results section.

The data is still available in the Query section and can be retrieved by 
repeating step 4 and selecting 1994 and 1995. One of the strengths 
of the Reporting section is that data can be added or deleted at will 
but is still available.

Summing up numeric data

BrioQuery can perform numeric calculations on columns of numeric data.

1 Click the Amount column to highlight it. 

2 Click on the Sum button on the Standard toolbar.

3 Scroll down to view the total amount of sales. PCW total sales for 
1994-1995 are $1,791,159.89. 

If you see ########, don’t panic. The number is too large to fit in the 
designated space. Resize the column, by choosing Format > Auto-
Size Column or by clicking on the column border and dragging it to 
expand its size. 
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If the figure does not match $1,791,159.89 it may be because you 
have limits imposed on Year and Quarter. Delete these items from the 
Limit Line and view the Sum again. The Sum is automatically adjusted.

Try out Format > Text Wrap for columns with text instead of data.

4 Click the Amount column again. Choose Results > Data Function and 
experiment with one of the other choices. 

Step Six: Pivot Your Data 
In the Sample file, the “Platform Analysis” tab is a simple example of 
a Pivot Report. Pivot reports are excellent for providing multiple angles 
on your data.

Click the Platform Analysis section tab.

Figure 2-7 Platform Analysis pivot section with illustration of pivot technique. 

Pivot reports allow you to quickly summarize data supplied in the Results 
section and immediately see the relationships between different 
dimensions of your data.These reports flexibly pivot to provide fresh 
angles of vision on your data.

Outliner

Dragging 
dimension 
handles to 
pivot report
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To create a Pivot Report

1 Choose Insert > New Pivot to create a new Pivot section tab. 

2 Scroll horizontally using the VCR buttons until you find the Pivot2 tab.

3 If the Outliner is not already visible, click Outliner on the Standard 
toolbar.

4 Experiment with dragging one or more different items from the 
Request line into each of the panels of the Outliner. 

5 Remove items from the Outliner and add new ones.

Figure 2-8 Pivot Set up.

For the following exercises, OS (Operating System) is in the left-hand 
panel of the Outliner, Year Number and Quarter in the top and 
Sum(Amount) in the data values area.

Tip  Use the top and left side panels for report labels. Use the 
remaining panel for values.

Use VCR buttons to scroll horizontally and 
find new section tab.

Click Outliner button to 
show Outliner Window
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To Pivot Views

1 Click the dimension handle at the end of the column or row labels 
(as illustrated in Figure 2-7 on page 2-9).

2 Drag the handle to turn your row into a column. Your same data is 
present but your angle on the data is quite different.

3 Now take the handle of the newly formed column and drag it so it 
again becomes a row.

To calculate totals

To make effective use of data, you may need to generate totals or 
calculate percentages.

1 First drag the “Item Type” and then “OS” to the left panel of 
the Outliner.

2 Drag Sum(Amount) to the values panel of the Outliner.

3 Select the dimension handle of the OS column (containing Mac/OS 
and Windows).

4 Click the Summation button  on the Standard toolbar to see 
the Total number of PCW sales for all operating systems by Quarter 
or Year.
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5 To calculate subtotals, select the handle of the Item Type (containing 
CD-ROM, Hard Drive...) and then click the Summation button. 
Subtotals appear for Windows and Macintosh.

Figure 2-9 Calculating totals and subtotals.

To drill-everywhere

There is more data available for analysis than you currently have 
represented in your Pivot report. 

1 Click the Dimension handle of the Operating System (OS) column in 
your Pivot.

2 Choose Pivot > Drilldown into and select Int Ext. 

Columns are added to your Pivot report showing PCW sales by 
external or internal hardware according to each operating system. 

3 If you feel lost, click on the Int Ext column and choose Pivot > Drillup 
to restore your view.

Note You can drill down by using the speed menu (Right-click the 
mouse in Windows and Motif; Ctrl-click on the Macintosh)

subtotals

totals
2-12 Part I:  Getting Started



D
E

S
IG

N
E

R
  •

  E
X

P
L

O
R

E
R

  •
  N

A
V

IG
A

T
O

R

To hide and focus on items

Suppose you now want to temporarily hide some of the data. 

1 Click a label such as Q2.

2 Choose Pivot > Hide Items (or Focus on Items).

3 To restore your excluded items, choose Pivot > Show All Items.

4 To restore the hidden data, choose Pivot > Show Hidden Items. 

To add color

You can add color, if you want to jazz up your reports.

1 Choose Format > Color Palette to show the Color Palette.

2 Select a Row or Column in your Pivot report.

• Alt-click a label for Windows.

• Option-click a label for Macintosh.

• Ctrl-Alt-click a label for Motif.

3 To change the color of the data, click your color preference in the 
Color Palette.

4 To change the background color, 

• Ctrl-click a color for Windows and Motif.

• Option-click a color for Macintosh.

• Ctrl-click a color for Motif.

UNIX

UNIX
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Step Seven: Charting Unlimited
BrioQuery’s charting features make powerful presentations and graphic 
analysis of data as easy as a drag and drop operation. In the Sample file, 
the Platform Sales Analysis is an example of a chart based on the data 
from the original query.

To go to the Chart section

Click the Product Sales Analysis section tab. 

Figure 2-10 Product Sales Analysis chart section.

To change the chart type and format

BrioQuery rapidly converts data from one chart type to another. 

1 Click the Chart Type buttons and view the data in different 
chart formats.

Note As you shift from one chart type to another, data may be 
shifted to different axes to enable the chart to represent the data.

2 In the pie chart, you can draw attention to individual slices by pulling 
them out of the pie. To do so, choose Format > Pie Slice Position and 
make a selection.

Chart Type 
Buttons

Legend 
button

Drag items from request 
line to Outliner panels
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To create a new chart

1 To create your own chart, choose Insert > New Chart.

2 If the Outliner is not already visible, click Outliner from the 
Standard Toolbar.

3 Practice dragging items to the Outliner.

Note Depending on the chart type, the y or z panels are most 
appropriate for numeric values. 

4 Click the Legend buttons to change the distribution of colors.

To sort your graph

It is frequently useful to order the bars of a graph sequentially or in order 
of values.

1 Choose View > Sort Line. Sort provides drop down menus to select 
sort criteria. Sort _____ by _____ using ____. Experiment sorting.

2 Now click the Ascending or Descending sort icons.  The 
chart orders the type in ascending or descending order by label.

To edit chart labels and change view 

You may want to change the label of your chart or the section tab.

1 Double-click in the Chart section Workspace to show the Chart 
Properties dialog box.

2 Type in a new title and subtitle for your chart.

3 Click OK.

4 Try experimenting with different settings for the various chart types. 
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Step Eight: Detail Reports
The Detail Report provides still another way of analyzing and presenting 
your data, providing a great deal of formatting flexibility, In addition, you 
can embed either a Pivot Report or Chart directly into a Detail report.

To go to the Detail section

1 Click the Sales Report section tab.

In the Sample file, the Sales Report is an example of a Detail report.

Figure 2-11 Another example of a Detail Report.

To create a new Detail report

1 Choose Insert > New Detail.

2 If the Outliner is not already displayed, click Outliner.

3 Try dragging items from the Request line to the Outliner. Use the 
values panel area for numeric data.

Note The Detail Report automatically generates sums for 
the data.

Drag Request 
line items to 
Outliner to create
Category 
headings, Labels,
and Values
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To format Detail reports 

You have a great deal of flexibility in repositioning items in your report.

1 Click one of the totals automatically generated in the report.

2 Drag the total from the bottom to the top of the column.

To add Graphics

You may add graphic enhancements to your report to emphasize data or 
simply refine the look.

1 Choose View > Toolbars > Draw. 

2 Create a space for inserting a graphic by clicking on the border of a 
row or column and dragging to expand its size. 

3 Click T on the Graphics toolbar to select the text tool. 

4 Click in the desired place in the report and drag to form a text box.

5 Type “Sales Report” in the window that opens.

6 Click the Rectangle tool on the Draw toolbar.

7 Click in the expanded row and drag to form a rectangle.

8 Use the Color Palette to assign a background color to the rectangle. 

9 Now click on the text and drag it over the rectangle. 

10 If the colored rectangle covers the text, click on the Send to Back icon 

on the Draw toolbar.

To create Smart Reports

You can embed other kinds of reports, such as Pivots and Charts, inside 
your Detail Reports to illustrate the data. 

1 Choose Insert > SmartReport.

2 In the Insert Report dialogue box, select one of the listed reports, such 
as Chart2 or Pivot2, to import your previously prepared report.

3 Click OK.

4 The inserted Pivot or Chart report can be adjusted in size. If necessary, 
expand the row to handle the size of the report. 
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Step Nine: Returning to Query
Your tour is almost over. You have seen some of the powerful 
functionality of BrioQuery reporting and the ease in which you can use it. 
But you have not yet learned how to generate an actual Query. 

This step presupposes a database connection. The database connection 
requires some work by a DBA (database administrator) setting up the 
connecting software and preparing what BrioQuery refers to as an OCE. 

For the BrioQuery Navigator

Navigators at this point will need to download pre-built DataModels from 
the repository. These Data Models will already have a pre-built query or 
enable the Navigator to make his or her own query. More detailed 
information about loading a Data Model and building a query is available 
in Chapter 5: Querying. 

To check for available Data Models

1 Choose DataModel > Repository Catalog.

If you are prompted to select an OCE, your administrator has not 
created a default OCE for you. Try Step 3 or speak to your 
administrator.

2 If a default OCE is available and you know the password, you are ready 
to connect. Click OK. 

You will log on to the database repository and can load already 
prepared DataModels.

3 If there is no default OCE, some preset OCEs may still be available. 
Choose DataModel > Connections > Select.

4 If OCEs have been prepared, they are listed in the window. Select one 
and click OK.

5 Ask the DBA for the appropriate password to connect.

To create a Query

1 If you have permission to create your own query, drag items from the 
Topics to the Request line. 

2 Click Process. Away you go!
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For the BrioQuery Explorer and Designer

As an Explorer or Designer, you have the ability to create your own Data 
Models and use these to build your queries. These topics are beyond the 
scope of this quickstart. For more information, refer to the following 
chapters Chapter 16: The Open Catalog and Chapter 17: Data Modeling.

Congratulations! You have finished your tour of BrioQuery. There is still a 
great deal more to learn about BrioQuery. But you now have a solid 
foundation for learning more advanced techniques. 
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Data is meaningless unless it can be analyzed and interpreted. Typically, 
a company database or datawarehouse is filled with thousands of 
discrete data elements that are of use only with analysis. To fully 
appreciate the power of BrioQuery to make sense out of uninterpreted 
data, it is useful to have an overview of the data analysis process. 

This chapter provides a conceptual understanding of the techniques 
involved in data interpretation and the way in which BrioQuery simplifies 
this process. It is written for the person who has little or no understanding 
of relational databases. While you can use BrioQuery without reading this 
chapter, it may help you to understand what BrioQuery is doing for you 
and improve your querying and analysis techniques.
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About Aggregation
Imagine if you had to look at each and every data value in your database 
to reach any conclusions about business trends or performance. You 
would probably throw up your hands in frustration. After all, most 
information in your company database is stored transaction by 
transaction. A large database may contain hundreds of thousands or even 
millions of discrete, tiny bits of information. Data warehouses, on the 
other hand, do not store discrete pieces of information but may contain 
an even more daunting number of records. Instead of storing transaction 
data for one part of your business, they often store consolidated 
information for all parts of your business.

When you ask a business question, it seldom concerns one or two 
particular transactions. Business questions are typically directed toward 
uncovering trends, anomalies, and possibilities in company performance 
and/or the marketplace. In short, business questions are asked from a 
macro perspective that may involve summarizing thousands of records 
at a time.

The activity of summarizing and consolidating records is often called 
“aggregation” in the technical vocabulary of database experts. 
Aggregation simply means that data is grouped and summarized by 
subjecting the data to some mathematical operation. The result is a 
summary of the data at a higher level. 

Consider a simple illustration: Suppose a company scanned into its 
database every transaction, including the date, price, item, amount of 
purchase, and location. To determine which item sold the most in 1996 
would require grouping each item by category and summing their totals.

Analysis, then, depends on consolidating data through mathematical 
operations that reveal meaningful relationships. 

However, it is the nature of relational databases for data to be dispersed 
or distributed in different tables. To find a meaningful relationship 
between different dimensions of data involves looking at the relationships 
among numerous tables. To understand this process, consider the 
database of a fictitious company, Personal Computer Warehouse.
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Introducing Personal Computer Warehouse
Many of the examples in this manual are based on the data warehouse 
of a fictitious company called Personal Computer Warehouse (PCW). 
In addition, BrioQuery includes sample files from the database of this 
company that you can view (see Chapter 2: A Tour of Brio Query). 
Understanding the structure of PCW’s database will help you follow 
many of the manual’s examples and provide you with a framework for 
understanding how to make the most of BrioQuery functionality.

PCW distributes desktop computer supplies to a number of computer, 
electronic and discount chains located throughout the United States. 
In order to predict trends and locate strengths and weaknesses in its 
distribution techniques, PCW warehouses extensive data. Figure 3-1 is a 
representation of several important tables in PCW’s data warehouse.

Figure 3-1 The structure of PCW database. 

Customers
Store
Store ID
Buyer
Store type
Street
City 
State 
Zip
Phone

Sales

Store ID
Item ID
Order Date
Delivery Date
Units
Amount

Periods
Day
Month_Name
Month_Number
Quarter
Year Number
Fiscal Month
Fiscal Quarter
Fiscal Year

Items
Item ID
Item Name
Int Ext
Item Type
OS
Dealer Price
Retail Price
Line Name
Line Description

=
=

=
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Each rectangle represents a table in PCW’s database. Connecting 
lines represent columns of data of identical type and format. Each of 
these tables has numerous rows of data. These four tables make up a 
data warehouse, a special kind of data base designed to make data 
analysis easier.

• SALES
Data about sales, such as units and amount sold and dates of sale and 
delivery. This is frequently called the “fact” table. The others are the 
“dimension” tables. 

• CUSTOMERS
Data about which stores purchased from PCW, including the location 
and the principal buyer.

• ITEMS
Information about the computer item sold, including, item type, name, 
operating system, type of component, and product series.

• PERIODS
A table of dates from 1/1/94-12/31/95 that allows PCW to organize 
other data by time periods, such as quarter and fiscal year.

Sample Data from PCW Database

Take a look at a sampling of data from each of the following tables.

Note how data is decentralized in the database. Each table is essentially 
a topic that contains relevant information. But most questions cannot be 
answered by a single table. Fortunately, there are intersecting columns of 
data or “joins” that enable you to associate data from one table with data 
in another. 
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DESIGNER  •  EXP

te Zip Phone

92121 615-546-6166

45254 617-434-7458

94621 510-729-7315

91221

91521 818-569-3240

Units Amount

50 898.75

35 2,571.63

25 449.38

45 3,306.38

25 549.38
LORER  •  NAVIGATOR

Table 3-1 Customers Tables

Store 
ID Store Buyer Store Type Street City Sta

28 Bayshore 
Electronics

Francisco 
Thompson

Electronics 31245 Flying Cloud San Diego CA

5 City 
Electronics

Fred Wolke Electronics 55 Walkers Brook Canton OH

10 Computer 
Central

Maxine 
Schneider

Computer 15 River Road Oakland CA

11 Computer 
Central

David 
McMahon

Computer Three Jacob Way Glendale CA

24 Computer 
Central 

T J Allen Computer 55 Penny Lane Burbank CA

Table 3-2 Sales

Store 
ID Item ID Order Date Delivery Date

1 1 9/19/1995 12:00:00 AM 10/3/1995 12:00:00 Am

1 3 7/6/1994  12:00:00 AM 7/11/1994 12:00:00 Am

2 1 5/4/1994 12:00:00 AM 5/7/1994 12:00:00 AM

2 3 3/20/199  12:00:00 AM 4/1/1995 12:00:00 AM

3 2 7/11/1995 12:00:00 AM 7/18/1995 12:00:00 AM
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