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10 Pivot Reports

Pivot reports provide a rapid way to summarize your data, enabling you to 
cut through the detail to reach a meaningful interpretation of your query 
results. Data summary is a simple drag-and-drop operation. And with the 
flexible pivoting feature you can easily reorient the summarized data to 
allow easy comparison of multiple dimensions of data. This chapter 
explains how to 

• create Pivot reports

• pivot data in the report 

• group items

• drill-down into the data

• manage data in the report

• perform calculations on your Pivot data



10-2 Part III: Reports

Analyzing Data with Pivot Reports 
When you first look in the Results of your Query, the data is not yet in a 
usable form. The Pivot report is designed to extract meaningful 
information from the Results section. 

Here is how Pivot works: By dragging data labels from the Request line 
into the Outliner, you select which dimensions to use in summarizing the 
underlying data in the Result section. In comparison with the Results 
section, a Pivot report almost always uses fewer dimensions to 
categorize the data. With fewer dimensions, BrioQuery can group and 
total the underlying values according to the selected dimensions. This 
process is a form of aggregation, which is described in more detail in 
Chapter 3: Turning Data into Information.

An Example of How Pivot Works

Suppose Paul Ryan, a senior vice president of Personal Computer 
Warehouse, designs a query to gather all the sales for a two year period, 
including information about the number of units, the amount of the sale, 
the store purchasing, the buyer involved and so forth. The data from this 
query initially would be quite unmanageable, returning more than nine-
hundred rows of data from the database. But with the Pivot report, the 
data can be quickly sifted and interpreted.
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Figure 10-1 Pivot Reports summarize and consolidate data from the Results section.

Using the Pivot report, it is easy to compare the amount of sales by 
product type for each of the years 1994 and 1995. 

Mr. Ryan drags the data labels “Year Number,” “Item Type,” and 
“Amount” to the Outliner panels (see Figure 10-1).

Automatically, BrioQuery displays the tallied sales amount for each 
Product Type by the year purchased. 

When Mr. Ryan adds “Quarter” into the Outliner, Pivot automatically re-
categorizes the data and provides new sums showing the sales in each 
year by Quarter.

Pivot Report Terminology

The Pivot report is composed of three different components: data labels 
data values and data dimensions.

• Data values are the numeric values that are broken up in the body of 
the pivot report.
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• Data labels are the column and row headings on the top and sides of 
the pivot report and define the categories by which the numeric values 
are organized.

• A Dimension is a full row or column of labels and corresponds to an 
item on the Request line. In Figure 10-2, for example, Year Number is 
a dimension of data that includes the labels, 1994 and 1995.

Figure 10-2 Pivot report and Outliner.

Creating a Pivot Report

In BrioQuery, you build a Pivot report by dragging one or more items from 
the Request line to various panels in the Outliner window. The top and 
side panels correspond to the top and side labels of the report. The 
bottom right panel holds the report values.

Top Label panel

Side Label panel

dimension
 handles

Top Labels

dimension 
handle

data values

Side Labels

Data Value 
panel
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To build a Pivot report

1 Click the Pivot1 section tab or Choose Insert > New Pivot to create a 
new Pivot report section.

2 Click Outliner on the Standard toolbar if the Outliner is not already 
available.

3 First drag data values (such as units or amount) from the Request line 
to the bottom right panel of the Outliner. 

4 Next, drag data labels into the other panels of the Outliner. (The 
maximum number of items you can use is 10 distributed between the 
top and side label panels).

Understanding Nested Labels

As your work with Pivot reports, you will quickly discover that labels from 
one dimension are frequently nested within labels from another 
dimension. Nesting means that one set of labels appears as a sub-division 
within each of the labels at a higher level of data.

Try placing more than one data label in an Outliner panel. The Pivot report 
will display the second set of labels inside each of the labels of the first 
data items. The second labels are nested within the first. This means they 
represent sub-divisions within another “higher level” category.

For example, Figure 10-2 shows Year and Quarter as data items in the top 
panel of the Outliner. The Quarter labels (Q1, Q2, Q3 and Q4) are nested 
within each year label (1994, 1995). 
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Techniques for Managing Your Data
Once you have the desired data in your Pivot report, a variety of 
techniques will enable you to more effectively analyze the data. These 
techniques change your perspective on the data without changing the 
actual data itself.

These techniques include 

• pivoting the data

• changing the hierarchical level of the labels

• focusing on or hiding various parts of the data 

• changing label names

• charting the pivot report

Using the Pivot Feature

You can reorient, or pivot, your reports on-the-fly by interchanging the top 
and side dimensions of the report. This Pivot feature is frequently helpful 
for juxtaposing data in one dimension with data from other dimensions. 
By pivoting the data from the top to the side, different relationships 
among the data become evident. 

To pivot your report

1 On the report itself, drag the dimension handle to the new location, or

2 You can drag a data from one label panel of the Outliner to the other 
label panel. 
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Figure 10-3 Re-orient your report by interchanging the top and side labels.

BrioQuery automatically re-organizes the data values and adjusts 
the labels.

Changing the Nesting of Labels

As previously discussed, labels have a nested relationship when more 
than one data item is placed in a single panel of the Outliner 
(“Understanding Nested Labels” on page 10-5).

But it is possible to reverse the nesting relationship. If labels for Quarter 
are nested within each labels for year, you can reverse the hierarchy. 
Each year (1994, 1995) can be displayed as a subset of each Quarter 
(Figure 10-4). In this case, Q1 values are broken down by the labels 1994 
and 1995. The data stays the same, but the emphasis is different. 

Pivot the report by 
dragging the dimension 
handle from one
label area to the other. 
The A label on the
top becomes the 
A label on 
the side.

A
B

A B
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To change the nested level of labels

1 With more than one data item in an Outliner panel, click on a data item 
in the Outliner.

2 Drag that item to the other side of the second data item in the same 
panel of the Outliner.

3 The labels in those dimensions will switch positions.

Figure 10-4 Changing the nested relationship of labels.

To change the order of labels within a dimension

Click a label name and drag it to another position within the current 
dimension.

The positions of Year and Quarter have been 
changed in the top label area of the Outliner.
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Selecting Pivot Elements and Using the Speed Menus

For a variety of tasks, such as hiding data or changing colors, you need to 
select Pivot rows, columns or dimensions. 

To select a Pivot row or column 

Alt-click a label for Windows.

Option-click a label for Macintosh.

Ctrl-alt-click a label for Motif.

Note Some PCX servers, such as Hummingbird, differentiate the 
right-alt and left-alt keys.

To select one or more contiguous items

Shift-click for Windows, Motif, and Macintosh.

To select non-contiguous items

Ctrl-click for Windows and Motif.

Command-click for Macintosh

To use Speed Menus

Right-click for Windows and Motif.

Ctrl-click for Macintosh.

UNIX

UNIX

UNIX

UNIX
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Grouping Labels Together

You can consolidate data from two or more rows or columns into a single 
item in the report with a single label. Grouping adds the data together, 
and replaces the original rows or columns with a single row or column 
displaying the consolidated figures. 

For example, you can group Q1 and Q2 into a single column.

To group labels

1 Click the names of the labels you want to group.

2 Click the Paper Clip button on the Standard toolbar.

Figure 10-5 Grouped labels in a Pivot report.

3 BrioQuery consolidates the values for selected rows or columns into 
a single row or column. 

Note By default, the label of the new column will be the label of 
the first item selected, marked with an asterisk (*) to indicate that 
it is a group of more than one item. To rename this row or column, 
see “Renaming Labels” .

 Q3 and Q4 
ready for 
grouping

Click paper 
clip to group

 Q1 and Q2 grouped into single item. 
Asterisk indicates a grouping
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To ungroup labels

Click on the grouped label, and click the Paper Clip button on the 
Standard toolbar.

BrioQuery restores the items to their original columns or rows.

Renaming Labels

For a variety of reasons, you might want to rename the labels. After 
grouping items, for example, you may want to use a more relevant label 
for the combined data.

To change the label of a group

1 Choose View > Toolbars > Format. 

2 Click a label name. The label is highlighted and the current name 
appears in the Format toolbar.

3 Type a new name in the Name field on the Format toolbar and press 
the Return key on your keyboard.

Figure 10-6 Rename grouped items with a descriptive name.

You can also double-click the label name and rename it in the Set 
Label Item dialog box.

BrioQuery displays the new name for the group.

Name selector



10-12 Part III: Reports

Adding Corner Labels 

You can add corner labels to your Pivot report which mirror the names of 
the data labels in the Outliner. You can also select the position of value 
labels in your report.

To add a corner label

Choose Format > Corner Labels and select an option. 

To change the position of Value labels 

Choose Format > Data Labels and select an option.

Hiding or Focusing on Data 

You can selectively restrict the data displayed in Pivot reports and Charts 
using the Focus and Hide features. Hidden data items are removed from 
the report but not the outliner. You can restore the hidden labels at 
any time. 

Focus and Hide are useful when you are most interested in a sub-set of 
the data and want to eliminate distracting detail. 

Corner labels mark 
dimensions of data 
according to items 
in the Outliner. Value labels can be 

placed on the top or 
side of the report 
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To focus on (or hide) report data

1 Select one or more label.

2 Choose Pivot > Hide Item (or Focus on Item).

BrioQuery updates the workspace to hide or focus the data. A 
drillbit appears in the Outliner next to the item in which data has 
been hidden.

Figure 10-7 Using the Focus command in a Pivot report

3 To restore the data, choose Pivot > Show Hidden Items (or Show All 
Items). For more information, see “To show hidden data” on page 
10-16.

Performing Drill-Down Analysis

Drill-down is a powerful feature that instantly provides detailed analysis 
for selected data items. When you spot a specific item that interests you, 
such as a top-selling product, you can drill-down into that item to find out 
more about it. If you want highly detailed information, you can 
progressively drill-down into your report to reveal the granular data.

Use the Focus 
command to display 
only specific label 
items in your Pivot 
reports. 
In this example, the 
Pivot report focuses 
on 1995.
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For example, you can determine if sales are higher in different geographic 
areas, and drill-down further to discover whether a particular store, or 
even an individual representative, makes significant contributions to 
total sales.

Since the drill-down feature retrieves data from the Results section, 
you can dig into your data as deeply as your original query permits. 

To drill down into a Pivot report

1 Select one or more labels for analysis.

2 Choose Pivot > Drilldown Into and select a dimension of data to view, 
or

3 Display the speed menu.

Figure 10-8 A speed menu displaying the Drilldown submenu.

The Drilldown submenu displays all the Request line items that are 
not yet in the Outliner.

4 Choose a drill-down item to break down the items you selected 
in Step 1.

BrioQuery re-displays the report, breaking out additional data 
according to the item selected for drill-down. In the Outliner, an item 
selected for drill-down is identified with a drillbit icon. 

Note If no options are available in the Drilldown submenu, all 
Request line items are already displayed in your Pivot report.
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Figure 10-9 The drillbit icon indicates drill-down analysis on an item.

To drill-up from the data

1 Click on the item below the drill-bit in the Outliner or click one of 
the items in the report itself.

2 Choose Pivot > DrillUp, or

3 Display the speed menu by clicking the right mouse button 
(Windows and Motif), or Ctrl-clicking (Macintosh) and then 
select DrillUp.

Showing Hidden Data

When the display has been restricted through use of the Focus, Hide or 
Drill-down features, you can restore hidden data to the display using the 
Show command options. 

Note For restoring data after a drill-down, you alternatively may want 
to use the Drill-up feature. 

Drillbit icon 
indicates that 
drill-down analysis 
has been performed 
on the item.
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To show hidden data 

1 Choose Pivot > Show All Items to restore all data hidden in the report 
as a whole, or 

2 Select a dimension for which you want to restore the full set of labels.

3 Choose Pivot > Show Hidden Items to restore all hidden data in that 
dimension.

Sorting in Pivot

Frequently, you may need to sort the values in given dimensions of your 
report. Sorting is discussed in greater detail in Chapter 9: Sorting.

To sort in Pivot reports

1 Choose View > Sort Line.

2 Use the Sort line to select a dimension to sort and the criteria by 
which to sort. 

Chart This Pivot

Once you have a final version of your Pivot report, try BrioQuery’s 
automatic chart generating feature. BrioQuery automatically creates a 
chart following the layout of the Pivot report. 

To automatically chart your Pivot report 

1 Choose Insert > Chart This Pivot.

BrioQuery creates a new bar chart using the data from the 
Pivot report. 

2 You are automatically moved to the chart section displaying the 
generated chart. 
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Figure 10-10 Chart This Pivot illustrated.

Data Calculations
The Pivot section provides a number of ways to perform data calculations 
to assist you in analyzing business trends. These calculations range from 
simple totals and subtotals that are useful in most reports to more 
complex data functions which are of use in more specialized contexts.

This section explains how to 

• add totals and subtotals to a pivot report

• use Data Functions to recalculate the values in a pivot report

• use Total Functions to change the values in totaled columns or rows

• distinguish surface and underlying calculations

• determine increase and percent increases

• use weighted averages

A chart automatically 
generated from a 
Pivot Report
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Adding Totals and Subtotals 

You can quickly add grand totals and subtotals to your Pivot report data. 
The totals and subtotals are created as additional rows or columns in 
your report.

To add totals or subtotals to reports

1 Click a Top or Side Label handle to select it. 

Selecting the outermost label creates a total; selecting an inner label 
creates a subtotal.

2 Choose Pivot > Add Totals or click the Summation button  on the 
Standard toolbar.

BrioQuery totals the data and displays the result as the last item of 
that dimension or category.

Figure 10-11 Pivot reports displaying grand totals and subtotals.

Select outermost 
dimension handle 
to determine 
Grand totals

Select innermost dimension 
handle to tally sub-totals
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Data Functions 

Data Functions enable you to change the nature of the values displayed 
in a Pivot report. Recall that when you create a Pivot report these values 
are automatically calculated. They represent sums of underlying values in 
the Results section (“Analyzing Data with Pivot Reports” on page 10-2). 

Frequently you may not want the values in your Pivot report to be sums 
of the original values. You may prefer to see averages or to determine the 
maximum or minimum values from the original data. Data values enable 
you to decide on the kind of value represented in the Pivot report. 

To apply a data function to a Pivot row or column

1 Select a row or column of data to which you want to apply a data 
function.

2 Choose Pivot > Data Function and select a function.

Each column or row cell value is recalculated according to the data 
function applied to the underlying data values. For a description of 
each type of data function, see Table B-3 on page B-6.

Putting Data Functions to valuable use

Data functions are particularly useful if you want your Pivot report to 
display different types of values side by side. For example, you can show 
the total sale, average sale, and maximum sale of each product by 
Quarter. Each of these dimensions is based on the same underlying 
values. They differ only in the data function that is applied.

By dragging the same numeric data item (such as “Amount”) from the 
Request line to the Outliner value panel several times, you can apply a 
different data function to the very same dimension. Each dimension 
refers to the same basic underlying values. But the calculation differs 
for each. 

To display summary values of different types

1 Drag a numeric data item from the Request line to the value area of 
the Outliner. 

2 Drag data labels into the Outliner panels.
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3 Again drag the same numeric data item from the Request line to 
the value area of the Outliner. You may repeat this procedure 
several times.

Figure 10-12 Different data functions applied to the same underlying values.

4 When you drag the same numeric data item to the value panel, the 
name changes to indicate how many times that item is in the Outliner 
(Amount_2, Amount_3)

5 Select a row or column of data values (such as Amount_2).

6 Choose Pivot > Data Function and select a function such as Average.

7 The data values are recalculated and averages populate the row or 
column of the Pivot report.

If desired, change the label of the new column or row (see “Renaming 
Labels” on page 10-11).

The same numeric data item 
has been repeatedly dragged 
to the value area of the 
Outliner

The same underlying data is interpreted 
with different data functions. 

Amount_2 represents Averages,
Amount_3 represents Maximum values.
Amount_4 is selected so that a data function can be 
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Total Functions 

Total Functions are identical to Data Functions with one major difference. 
Data Functions can be applied only to the underlying values. Total 
Functions can be applied to either: 

• the underlying values from the original results section or 

• the “surface” values displayed in the Pivot report

With most Total functions, the two approaches yield different results, 
and produce values that may appear incongruous with the values in 
the report. 

Understanding Surface and Underlying Values

To understand this difference between “underlying” and “surface” 
values, consider a simple Pivot report with two values of 20 and 30. Each 
of these is already a total of underlying values (20 = 8 +12 and 30 = 10 
+ 20). An average of the underlying value yields the result of 12.5 = (8 
+12 + 10 + 20) / 4). An average of the surface values yields the result 25 
= ((20 + 30) / 2).

To provide the flexibility of computing totals in either manner, BrioQuery 
enables you to apply total functions to either underlying or surface values. 

For a list of surface functions available see Table B-3 on page B-6.

Total Functions are Applied to Totalled Rows or Columns

Total functions are useful for changing the nature of values displayed in 
summary rows or columns. For example, imagine you first totalled the 
amount of sales for each product in 1994 and 1995. The values in the 
totalled rows could be changed from a sum of the total underlying data to 
an average of the total underlying values. 

Total Functions, then, are data functions applied to rows or columns 
which were created by previously totalling dimensions of data (“Adding 
Totals and Subtotals” on page 10-18). 
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To apply a Total Function

1 Create totals or subtotals in your Pivot report.

2 Select a row or column representing totalled values. 

3 Choose Pivot > Total Function and select a function.

Putting Total Functions to Valuable Use

Total Functions are particularly useful when you add more than one total 
row or column to your report for the same dimensions. For example, you 
can total Yearly amounts 3-4 times and then apply different data functions 
to each of the Totals. In this way, your Pivot report contrasts the sums 
with other kinds of values such as averages, max values, % of row.

To display multiple kinds of totals

1 Select the dimension handle for a particular dimension of data.

2 Click on the Summation icon to produce totals.

3 Repeat steps 1-2 to produce an identical row or column of 
totalled data.

4 Select one of the rows or columns of totalled data.

5 Choose Pivot > Total Function and select a function. 

6 Repeat steps 4-5 with another row or column of totalled data.

Now the two rows or columns of totalled data show contrasting 
values. One displays a total of the sums. The other displays totals of 
the averages.
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Figure 10-13 Total Functions applied to two columns of totalled data.

Calculating Increase and Percent Increase

Increase and %Increase are special calculations that you can use to 
calculate the difference between the final two columns or rows of data 
within a single dimension. Use Increase to show the increase in the 
number of units between columns. Use %Increase to show the 
percentage of increase in units between columns.

For example, if the dimension Year contains labels for 1993, 1994, and 
1995, an Increase function calculates the difference between the totals 
for 1994 and 1995. 

Two columns of Totalled Data. One representing 
sums of the data. The other representing averages.
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To show unit or percent increase

1 Select a dimension handle and click Summation to calculate a total or 
subtotal for a dimension of data.

2 Alt-click (Windows and Motif) or Option-click (Macintosh) on the label 
for the totalled data.

3 Choose Total Function > Increase (or %Increase).

BrioQuery recalculates the total to display the unit (or percent) 
increase between the last two data columns. 

Figure 10-14 Pivot report displaying %Increase.

Some Tips about Increase Calculations

If you want to display increases for the values represented in your Pivot 
report, apply the increase function to the innermost dimension of data. 

Increase functions compare the last two values in the dimension of data 
nested immediately below the level at which the calculation occurs. 
For example, imagine data is organized in three tiers (Year, Quarter, 
Operating System). If you calculate a total for Years and perform an 
increase function on that total, BrioQuery calculates the increase 
between the last two Quarters (Q3, Q4), even if you have not created 
a sub-total for the Quarter dimension. This is the next dimension of data 
immediately below Year in your Pivot Report.

The total column 
displays results of 
increase formula 
applied to the two 
columns of values

The report displays 
two columns of 
values for the 
Year item—1994 
and 1995
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Weighted Functions 

Weighted averages can be very useful for a variety of purposes such as 
survey research or any time you want to include demographic information 
in your reports. For example, suppose you took a survey of 100 people, 
75 male and 25 female. But according to census data in that geographic 
region you should have surveyed 50 males and 50 females. The data you 
have is skewed toward males. 

To correct for this, you assign a weight or "weighting factor" to correct for 
the sampling error in your survey. To calculate a weight you take the 
expected amount divided by the actual amount. 

In the example, the men would have a weighting factor of .6666 (50/75) 
and the women would have a weight of 2 (50/25). Any calculation would 
calculate each man as .6666 and each woman as 2.

Weighted Averages can also be used to apply different levels of 
importance to a given item. Take, for example, a survey which has 
multiple questions. The responses can be rated on a scale of 1 to 5. By 
assigning a weight to each question based on the level of importance (the 
higher the number the more important), and using that weight in 
calculating a weighted average, you can arrive at averages that are more 
meaningful.

Setting up Weighted Values 

To use weighted values, a column of data must be added to the database 
indicating the relative weight of each corresponding value in another 
column. The statistical calculation for weighted averages depends on the 
following mathematical formula (c * w) / sum (w). 

Customer ID Units Sold Type of Store Weight

1435 80 Electronics 8

1539 200 Computer 10

1634 60 Electronics 8

1213 900 Discount 2



10-26 Part III: Reports

Figure 10-15 Using Weighted Averages 

To use weighted averages or functions

1 A column of data with the weighted values must exist in the database.

2 In the Query section, select a data item for which weight values 
are needed.

3 Choose Query > DataFunction > Weight.

A Reference window opens prompting you to indicate where to find 
the column of weighted values.

4 Select the data item containing the weighted values and click OK. The 
item in the request line is renamed indicating it is a weighted value.

5 Process the Query. 

The Weighted values are returned in the Results section.

In the Query section, one data item 
selected for weighting

Reference window opens prompting you to select 
the data item where Weight values are located.
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6 Go to the Pivot section and drag the Weighted item to the Outliner.

Note Weighting functions work in the Pivot report only. 

7 You may now use all the various Data Functions (e.g., averaging, max, 
min) on the Weighted values. 

Figure 10-16 Use of weighted functions in the Pivot Report.

Computed Items

Computed Items enables you to design calculations that you wish to 
perform on each of the values represented in a Pivot dimension.

For example, if you wanted to know how much of the total sales in a year 
was sales tax, you could ask BrioQuery to calculate the sales tax for each 
sale and subtract it from the totalled value and represent the new data in 
its own column.

Computed Items are discussed in detail in Chapter 8: Computed Items. 

A Pivot report with a Weighted Amounts 
column compared to non-weighted values.

A self-
generated item 
appears in the 
Outliner
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Where To Go From Here
BrioQuery offers a number of tools and features for formatting Pivot 
Reports. See Chapter 13: Common Report Features, for information on: 

• applying color

• using the Spotlighter

• exporting your reports

• duplicating your reports

For general formatting and printing information, refer to Chapter 4: 
BrioQuery Fundamentals




